Что нового в последней версии ГИС Карта 2005

ГИС Карта 2005

Версия 9.15.5

1). Доработаны средства построения и анализа сетевой модели в задаче Расчеты по карте. Доработаны средства сбора семантических характеристик
узлов и дуг сети с исходной карты. При формировании отчетов по построенным маршрутам используется семантика узлов "Собственное название". Для выбора
узлов, по которым должен проходить маршрут, можно использовать текстовый файл со списком собственных названий узлов. Отчет с описанием участков маршрута может быть сохранен в Excel с добавлением указанных пользователем характеристик участков. Длина участков округляется до заданной точности.

2). Доработана задача "Подключение GPS-приемника". При старте задачи для удобства работы пользователя с несколькими разными задачами создается панель с кнопками: Скрыть/Показать диалог "GPS-монитор"; Подключить/отключить GPS-приемник; Выбрать значек для отображения текущей точки; Включить/Отключить индикатор режима работы GPS-приемника; Закрыть задачу GPS-монитор.
При включении кнопки "Индикатор режима работы GPS-приемника" меняется цвет фона кнопки в зависимости от способности GPS-приемником определять координаты точки (красный - не доступно, желтый - 2D, зеленый - 3D). Добавлено отображение координат текущей точки (СК-WGS84) в строке состояния главного окна.

3). Доработана задача "Формирование протокола GPS измерений" (GPSPROTC.DLL). Добавлен новый отчет "Схема расположения базовых и определяемых станций", с возможностью настройки вида условных знаков и параметров формирования и печати схемы.

4). Добавлена поддержка системы координат 95 года при создании топокарт.

5). Изменен алгоритм прозрачного отображения растров и матриц для просмотра набора перекрывающихся снимков, матриц и карт в различной последовательности.

6). В диалоге Редактирование семантики добавлена возможность работы с набором объектов. Если объект входит в Набор, то появляется новая закладка.

7). В диалоге Выбор объекта добавлена возможность редактирования палиты CMYK для уточнения цвета выбранного объекта. Палитра выбирается в диалоге Выбор цвета из закладки Вид или На печать. В параметрах подписи добавлена возможность выделения объекта по контуру заданным цветом. Предназначена для прочистки подписи при издании карт.

8). Добавлена возможность Импорта и Экспорта в текстовый файл списка значений семантики типа Классификатор.

9). Добавлена возможность вызова клиента Google Earth для просмотра изображения текущей точки карты на космической съемке.

10). Обеспечено согласование штриховки соседних объектов одного типа в принтерном виде для печати геологических карт.

11). Для задачи "Создание матрицы качеств" добавлен новый метод построения поверхности - логарифмическая интерполяция по локальной поверхности
вокруг определяемого элемента.

Версия 9.15.4

1). Доработана задача "Подключение GPS-приемника".
Добавлен выбор USB-порта и автоопределение подключенных устройств. Добавлена обработка данных по протоколу Garmin через USB-порт, считывание путевых точек и маршрутов и сохранение их на карте, считывание TrackLog'a (след, курс). Добавлена кнопка ОТЛАДКА для записи поддерживаемых протоколов и другой информации в журнал (Закладка СЕРВИС).

2). Усовершенствована задача трехмерного изображения карты (Задачи\Навигатор 3D).
Добавлена средства трехмерного отображения подписей. Текстура для подписи берется по виду знака (подписи). Таким же образом можно выбирать текстуры по виду двухмерного знака и применять их в трехмерных моделях векторных и точечных объектов.

3). Доработана задача "Геодезические вычисления":
- диалог "Теодолитный ход" позволяет вводить и обрабатывать геодезические измерения в трех вариантах (плановая съемка, плановая съемка + dH-превышение, планово-высотная съемка);
- диалог "Прямая задача" позволяет вводить и обрабатывать геодезические измерения в трех вариантах (плановая съемка, плановая съемка + dH-превышение, планово-высотная съемка).

4). Доработана задача "Формирование межевых дел":
- процесс формирования землеустроительной документации дополнен функциями, обеспечивающими создание отчетов для обособленного земельного участка (отдельный объект карты), для единого землепользования (несколько объектов карты, включенных в общий набор) и для группы выделенных объектов (потоковая обработка). Примером единого землепользования является земельный участок под опорами нескольких ЛЭП, отнесенных к одному фидеру.
- усовершенствован механизм отображения связанных с картой записей (запись выделяется желтым цветом, подсчитывается количество частей участка, в том случае если это единое землепользование, запрашивается значение площади объекта и выдается в соответствующее поле; расширен перечень полей для атрибутивных данных об участке; добавлена возможность хранения информации о результатах полевых измерений (файлы TEO, TPR TOB) с персональной привязкой для каждого отдельного участка.
- при формировании "Межевого дела" для одиночных участков добавлена возможность поиска, обработки и выдачи в отчет информации о соседних участках.
- при формировании схемы землепользования добавлен контроль повторного нанесения на карту одинаковых точек. Например, нанесена поворотная точка участка, а затем наносится угловая точка строения, соответствующая поворотной точке участка. Теперь двойные точки не наносятся. В результате на схеме нет двойных объектов, а в отчете пространственно одинаковые точки имеют одинаковые имена.
- при формировании отчетов добавлена обработка новых ключевых полей в шаблонах документов:
NTS - название отрезка метрики участка (т.у.1 - т.у.2);
NTSOBJ - название отрезка метрики строения (т.с.1 - т.с.2);
OPB - описание прохождение границы отрезка метрики участка;
OPP - описание закрепления поворотной точки участка;
OSB - описание прохождение границы отрезка метрики строения;
OSP - описание закрепления поворотной точки строения;
FD - допустимое расхождение координат и мер линий;
SD - допустимое расхождение площадей.
- при формировании схемы с учетом расположения участка в пределах кадастрового квартала на дежурной кадастровой карте добавлена возможность формирования условного внешнего зарамочного оформления (на сленге «АБВГД-ейка» или "морской бой"). Данная функция добавлена для оперативного создания отчетов без нанесения на карту объекта - кадастровый квартал.
- для режимов, использующих выбор объектов карты, добавлены вспомогательные режимы "Захват чужой точки" (клавиша К) и "Захват чужой линии" (клавиша Т). Для ряда режимов внесены функции ведения и использования журнала транзакций.

5). Разработаны новые режимы в задаче "Геодезический редактор":
- «Формирование схемы объекта» в виде пользовательской карты без последующего формирования отчета в Word;
- «Нарезка площадей» - обеспечивает создание новых объектов заданной площади или нарезку исходного полигона на N новых площадей равной площади;
- «Увеличение площадей» - обеспечивает интерактивное увеличение площади выбранного объекта, путем перемещения указанного отрезка метрики. В ходе перемещения пользователь получает возможность визуально контролировать величину новой площади объекта.
- «Формирование абрисов поворотных точек объекта» - позволяет указывать привязку для указанных поворотных точек по желанию пользователя. Выбор привязки для поворотной точки осуществляется интерактивными методами;
- «Создание объектов из файла *.cxyz» - предназначен для потоковой загрузки большого количества точечных объектов (более 1 000 000) и может быть применен при чтении измерений воздушного лазерного сканирования местности;
- «Формирование подписей геодезических координат точек объекта» - функционирует только для карт, поддерживающих геодезическую систему координат;
- «Отображение координат точек объекта» - обеспечивает интерактивное подписывание поворотных точек выбранного объекта. Надписывание координат производится для указанной пользователем точки;
- «Отчет по измерениям методом полярных координат» и формирование схемы по измеренным данным. Вызывается из диалога «Решение прямых геодезических задач»;
- «Построение профиля линейного сооружения» - предназначен для построения профиля по выбранному объекту или набору объектов. В результате выполнения данного режима формируется схема линейного сооружения, на основе координатного описания оси трассы.

6). Разработана новая задача "Расчет объемов земляных работ" (MASSES.DLL).
Предназначена для определения объемов земляных масс, подлежащих перемещению в пределах локального участка местности и формирования схемы земляных работ в виде пользовательской карты. Исходными данными являются две матрицы высот: топографической поверхности и проектной поверхности. В задаче предусмотрен расчет объемов двумя методами: по рабочим отметкам в узлах сетки плана земляных работ и по элементам матриц. Рассчитываются следующие показатели:
- сумма положительных значений (насыпка грунта);
- сумма отрицательных значений (выемка грунта);
- сумма значений по модулю (суммарный объем земляных работ);
- абсолютная сумма значений (баланс земляных работ).

7). Разработана новая задача "Создание матрицы качеств".
Предназначена для построения поверхности, отражающей изменение заданного моделируемого параметра (семантической характеристики). Построение может быть выполнено по точечным объектам векторной карты с заданной семантической характеристикой или по базе данных, содержащей результаты точечных измерений характеристики. Результатом построения является файл матрицы качеств (*.mtq). Палитра отображения матрицы настраивается при создании. Кнопка вызова задачи на панели Операции с поверхностями в задаче Расчеты по карте.

8). Разработана новая задача "Привязка карты по двум точкам" (VECADAPT.DLL).
Предназначена для преобразования карты из местной системы координат к системе 42года по геодезическим координатам в системе 42 года или WGS84. В результате создается новая пользовательская карта, полученная в результате параллельного переноса (привязка по одной точке) и поворота исходной карты (привязка по двум точкам). Координаты точек могут быть получены с ГЛОНАСС\GPS-устройств.

9). Разработана новая задача "Конвертор из формата ASCII KLT" (KLT2MAP.DLL).
Предназначена для для загрузки картографических данных из формата ASCII KLT системы ATLAS в пользовательскую карту системы Панорама.

10). Доработана задача "Нанесение разграфки" (MAPRULE.DLL).
Добавлена возможность донанесения разграфки на ту же карту (в том числе, несколько районов за один сеанс) и возможность ввода ширины и высоты при нанесении произвольных рамок листов.

11). При сохранении изображения карты или растра в форматы TIFF и BMP может быть сформирован файл TAB с установленными параметрами привязки изображения.

12). В меню Параметры добавлен пункт Колесико мыши для выбора реакции на вращение - масштабировать карту или перемещать (во втором случае для масштабирования нужно нажимать CTRL).

13). Доработан диалог "Сохранение карты в файл графического формата" (BMP, TIFF...).
Добавлено потоковое сохранение графических файлов по габаритам выделенных объектов. Формирование имён файлов выполняется по порядковому номеру, по номеру объекта, по информации из указанной семантики.

14). Добавлено ведение журнала транзакций при обновлении карты из файлов SXF, TXF.
Позволяет контролировать и отменять результат обновления в диалоге Отмена последней операции Редактора карты.

15). Обновлены конверторы в формат IN4 и обратно (введен приказом Государственного комитета по земельным ресурсам Украины от 23.05.2003 года № 136). Выложены на сайт для скачивания.

Версия 9.15.3

1. Доработан диалог Создание плана. Позволяет создавать план с заданной точностью хранения координат (сантиметры, миллиметры, максимальная точность).
При любых редактированиях такого плана число значащих цифр в метрике сохраняется. Все расчеты выполняются в соответствии с числом хранимых знаков в координатах, что обеспечивает постоянную заданную точность результатов во всех задачах.
В описание SXF внесено описание поля Флаг точности координат вместо резервного поля для сохранения\восстановления точности при конвертировании.
В описание паспорта TXF внесено описание поля P901 (точности координат) для сохранения\восстановления точности при конвертировании.

2. Доработана задача "Сортировка данных". Обеспечивает преобразование точности хранимых координат объектов к заданной (сантиметры, миллиметры, максимальная точность).
При хранении координат с точностью сантиметры или миллиметры меняется версия формата данных карты. Для возврата к прежней версии формата необходимо выполнить повторную сортировку с максимальной точностью хранения координат или нормальной точностью. Структура формата SXF остается общей для всех версий программ. Структура формата SXF остается общей для ВСЕХ версий программ. Обеспечена сортировка карт с размеров файлов более 2 Гбайт.

3. Доработана задача "Геодезический редактор":
- При формировании схемы землепользования (режимы: МЕЖЕВОЕ ДЕЛО, ОПИСАНИЕ ЗЕМЕЛЬНОГО УЧАСТКА, ОБРАТНАЯ ГЕОДЕЗИЧЕСКАЯ ЗАДАЧА) добавлена проверка нанесения на карту топологически одинаковых точек. Например, нанесена поворотная точка участка, а затем наносится угловая точка строения, соответствующая поворотной. Теперь двойные точки не наносятся. В результате на схеме нет двойных объектов, а в отчете топологически одинаковые точки имеют одинаковые имена.
- При обработке единого землепользования первым в отчет выводится главный объект набора - единое землепользование.
- Улучшены функции автоматического формирования подписей на схеме участка. Подписи наносятся в строгой иерархии: номер точки, внутренний угол, внешний угол и т.п. Раньше встречалось наложение подписей.
- Добавлен новый режим: "Нарезка площадей". Режим обеспечивает создание новых объектов заданной площади или нарезку исходного полигона на N новых площадей равной площади.
- Для режимов, использующих выбор объектов карты, добавлены вспомогательные режимы "Захват чужой точки" (клавиша К ) и "Захват чужой линии" (клавиша Т ).
- Для ряда режимов внесены функции ведения и использования журнала транзакций.
- Создан новый режим "Формирование абрисов поворотных точек объекта". Режим позволяет указывать привязку для указанных поворотных точек по желанию пользователя. Выбор привязки интерактивный.
- В диалоге "Формирование схемы документа" исключена обработка абрисов. Теперь они обрабатываются специальным режимом.
- В диалоге "Формирование межевых дел" включена возможность формирования абрисов при помощи специального режима.
- Добавлены новые ключевые слова NTS-номер отрезка метрики землепользования, NTSOBJ-номер отрезка метрики внутреннего объекта.
- Изменен механизм формирования схемы для состава объектов схемы: «Участок и все объекты с этой карты» и «Все объекты со всех карт документа». Внесены изменения в выбор названия точек из семантики межевых знаков и порядок сквозной нумерации точек участка и строений.
- Добавлен элемент, управляющий исключением замыкающей точки (повторение 1 точки) полигона при формировании отчетов. Пользователь управляет данной возможностью в диалоге "Формирование схемы участка" на странице "Параметры отчета".
- Добавлена возможность формирования «АБВГД-ейки» ("морской бой") без наличия на карте объекта - кадастровый квартал.
- Устранен поиск соседних участков, граничащих одной точкой.
- При подписи площади на плане добавлена размерность (кв. м., кв. км., га).
- Разработана новая функция "Формирование схемы объекта" в виде пользовательской карты без последующего формирования отчета в Word.
- При формированиии схемы объекта для единого землепользования учитывается главный объект набора. Нумерация точек начинается с него, поворотные точки остальных объектов по номеру объекта на карте.

4. Доработана задача "Геодезические вычисления":
- В диалоге "Построение теодолитного хода" внесены изменения в формирование схемы теодолитного хода.
- В диалоге "Построение теодолитного хода" при импорте данных формат угловых величин устанавливается согласно установленному формату в диалоге "Параметры проекта для геодезии и землеустроительной документации". Исправлена ошибка занесения высоты в массив координат точек.
- В диалоге "Решение прямых геодезических задач": при импорте данных формат угловых величин устанавливается согласно установленному формату в диалоге "Параметры проекта для геодезии и землеустроительной документации".
- В диалоге "Решение обратных геодезических задач. Площадь участка" добавлены дополнительные параметры для редактирования схемы и печати документа.
- В диалоге "Нивелирование" изменено распределение остатка невязки превышения.

5. Доработана задача "Импорт геодезических измерений с приборов".
Добавлена обработка формата GTS-6 для электронных тахеометров GTS-220/210/310/GPT и форматов LEICA - IDX,GRE,GSI. Доработана поддержка форматов SDR (Sokkia) и GTS-6 (TOPCON, SOUTH NTS-325, NTS-320, NTS-350).
В обработку формата GTS-600 добавлен учет обратного измерения.

6. Доработана задача "Редактор карты". Обновлен режим "Добавление семантики" - добавлена возможность составлять новое значение строки в виде выражения, включающего значения различных семантик объекта и заданный постоянный текст.
В панель Высота задачи Редактор добавлен режим Удаление высоты для выбранного объекта или выделенных объектов.

7. Доработана задача "Подключение GPS-приемника". На закладке "КООРДИНАТЫ" добавлена возможность выбора системы координат для отображения текущей точки (система координат 1942 года - метры или градусы, минуты, секунды; система координат ПЗ-90).
Добавлена новая закладка "СПУТНИКИ". Содержит значения факторов, ухудшающих точность определения координат точки (PDOP, HDOP, VDOP); изображение условного расположения спутников на небесной сфере (Альманах); схему относительной силы сигналов спутников.
На главной панели диалога добавлено отображение режима функционирования GPS-приемника (2D, 3D, не готов к решению навигационной задачи).

8. Доработан конвертор в формат DXF для конвертирования выделенных объектов с нескольких карт в один файл.

9. Усовершенствована задача трехмерного изображения карты (Задачи\Навигатор 3D).
Добавлена отрисовка объектов, не имеющих назначенного в классификаторе трехмерного вида: линейные и площадные объекты - по контуру линией c параметрами из двухмерного изображения, точечные объекты - точками соответствующего цвета. Это позволяет отображать в 3D-модели результаты лазерного сканирования местности и другие данные. Для просмотра данных лазерного сканирования появилась возможность отключения отображения поверхности 3D-модели (в меню "Вид/Вид поверхности/Отсутствует"). Трехмерную модель местности теперь можно просматривать не только в перспективе, но и в ортогональной проекции (без искажения размеров объектов).
Добавлен диалог изменения максимальной высоты подъема наблюдателя и границ масштабирования модели (в меню "Модель/Изменить настройки").

10. Доработана задача "Контроль качества векторной карты". Обновлены контроли входимости подобъектов, определения недопустимых кодов объектов, габаритов объектов относительно рамки листа, наличия разрывов объектов, количества точек у рамки.

11. Доработана задача "Мультипликация данных" (MULTIPLY.DLL).
Добавлена панель кнопок для вызова режимов, аналогичных стандартному мультимедийному проигрывателю: В начало, В конец, Предыдущий, Следующий, Начать непрерывный показ (воспроизведение - мультипликация), Остановить показ (стоп), Приостановить показ (пауза).

12. Доработана задача "Построение горизонталей по матрице высот" (MTWTOMAP.DLL). Исправлена ошибка аналитической обработки данных при отсутствии значений высот (например, псевдокоды за рамкой матрицы). Добавлена новая встроенная функция устранения "зубчатости" горизонталей. Добавлена возможность выбора способа и степени сглаживания горизонталей.

13. Доработана задача "Расчеты по карте". При построении зоны затопления по координатам отметок уровня воды из текстовых файлов добавлена поддержка геодезических координат в форматах NBLH и BLH. Где B и L - градусы в системе 42 г., H - относительная высота или B и L - градусы в системе WGS, H - относительная высота, N - номер точки.

14. Доработан диалог Список растров. Позволяет устанавливать параметры проекции сразу всем растрам из списка.

15. Доработан импорт растров с привязкой по файлу TAB. Если рамка привязки не совпадает с реальным положением растра, то автоматически выполняется его трансформирование по заданной рамке.

16. Доработана задача "Загрузка матрицы из формата SRTM" (SRTM2MTW.DLL).
Добавлена возможность выравнивания размерности элементов матрицы для устранения пунктирных линий на стыке нескольких смежных матриц, трансформированных в заданную проекцию.

17. В главное меню добавлен пункт Файл\Добавить из директории. Позволяет добавить к основной карте все файлы заданного типа (растры, матрицы, пользовательские карты). Пункт меню Файл\Добавить пользовательскую карту позволяет выбрать файлы TXF и SXF. Если файл TXF был получен из карты местности (MAP), он может быть преобразован к пользовательской карте. Это позволяет открыть одну карту типа MAP поверх другой.

18. В главное меню добавлен пункт Параметры\Система координат\Геодезическая (Параметры Земли - 90, ГЛОНАСС) для отображения координат текущей точки в системе ПЗ-90.

19. Доработан интерфейс Редактора классификатора . В диалогах Слои и Семантика yбрана сортировка по радиокнопкам. Сортировка выполняется по нажатию на заголовок столбца.

20. Доработан классификатор морских карт S57navy.rsc по стандарту S52 (редакция - март 2004 г.). Добавлены изображения знаков, расположенных в центре площадного объекта, таких как "Якорные стоянки" (ACHARE), знаки системы разделения движения (TSSLPT_S) и различные специальные области (CTNARE_S). Для объектов имеющих семантики RESTRN ("Ограничения") разработаны процедура отображения знаков - ограничений, по правилам S52. Изображение точечных знаков дополнено текстовыми метками, отображающими значения характеристик объекта с добавлением префиксов и постфиксов (форматированная строка).

21. Доработано отображение подписей в разных масштабах. Обеспечено более точное соблюдение высоты шрифта и длины текста при печати карт и подготовке к изданию.

22). Доработано обновление карт местности и пользовательских карт с помощью меню Файл\Обновить. Доработано обновление листов карт из файлов SXF, TXF, открытых пользовательских карт и карт местности. Обновление карты методом "добавление" позволяет переносить объекты без выполнения множества действий в Редакторе карты.

23). Разработана новая программа - "Конвертор крупномасштабных планов в формат DXF ". Обеспечивает конвертирование в формат DXF и автоматическое преобразование условных знаков из классификатора ГИС Карта 2005 в эталлонные условные знаки для AutoCAD.

24). В инсталляцию ГИС Карта 2005 версии 9.15.3 добавлена автоматическая установка BDE (необходима для работы Геодезических задач и Базы данных). Инсталляции версий 9.15.1 и 9.15.2 требовали дополнительной установки BDE (из папки \System\BDE на CD).

Версия 9.15.2

1. Добавлена новая задача "Загрузка матрицы из формата SRTM" (SRTM2MTW.DLL). Позволяет загружать матрицы высот рельефа, полученные методом радарной топографической съемки (SRTM). Входными данным процедуры являются файлы с расширением HGT, соответствующие одноградусному блоку территории земного шара. В результате работы программы формируется файл в формате MTW с трансформированием матричных данных. Геодезические параметры (вид эллипсоида, проекция и система координат) создаваемой матрицы берутся из исходной карты, для которой выполняется загрузка информации.

2. Добавлена новая задача "Построение матрицы уклонов" (INCLINE.DLL). Предназначена для создания матрицы уклонов по матрице высот. Одновременно создаётся карта уклонов, в которую заносятся векторные объекты – направления уклонов. Значение уклона вычисляется в градусах для всех восьми соседних элементов и в матрицу записывается максимальный из них.

3. Добавлена новая задача "Дорисовка векторной карты на растре" (MAP2RSW.DLL). Предназначена для обновления отдельного растрового изображения векторными объектами.

4. Доработана задача Расчеты по карте. Добавлен режим "Построение минимального пути между набором заданных точек" для работы с сетью.

5. Доработана задача Редактор карты. Обеспечивается изменение типа объекта в любой другой (ранее были ограничения). Поддерживается создание подписей по координатам из файла.

6. Доработана задача Геодезический редактор. При формировании отчетов добавлена обработка новых ключевых полей:

NTS - название отрезка метрики участка (т.у.1 - т.у.2);
NTSOBJ - название отрезка метрики строения (т.с.1 - т.с.2);
OPB - описание прохождение границы отрезка метрики участка;
OPP - описание закрепления поворотной точки участка;
OSB - описание прохождение границы отрезка метрики строения;
OSP - описание закрепления поворотной точки строения;
FD - допустимое расхождение координат и мер линий;
SD - допустимое расхождение площадей.

Исправлена ошибка отображения габаритов участка (группы выделенных участков) при изменении масштаба и повторной загрузке процедуры. Добавлено исключение обработки замыкающей точки полигона при формировании "Описания земельного участка".

7. Внесены изменения в интерфейс редактирования полей в различных диалогах (ввод значений и переход между различными полями без обязательного нажатия клавиши Enter).

8. Изменено размещение файла Panorama.ini - в директории %user%\Application Data\. При первом запуске содержимое файла копируется из директории ГИС в данную директорию.

Версия 9.15.1

1). Обновлена задача Подключение GPS-приемника. Добавлен режим "Поворот карты по ходу движения" - объект всегда направлен на север, а карта поворачивается в соответствии с его курсом.
Добавлены тестовые режимы для имитации приема сигнала:
- движение по выбранному объекту;
- движение по данным из файла формата NMEA 0183.
Добавлена возможность выбора условного знака для движущейся точки и сохранение в INI-файл при закрытии диалога и восстановление настроек задачи.
Добавлено отображение скорости движения объекта и времени определения текущей точки для реального режима и для тестового режима "Загрузка протокола формата NMEA0183..." ($GPZDA и $GPVTG).
Добавлена посылка сообщения "ATA" устройству CellRoute-GPRS(TelecomFM) при открытии порта для автоматического перевода в режим ожидания звонка.
Добавлено сохранение в соответствующих семантиках время начала и время завершения создания линейного объекта.
Для тестового режима "Загрузка протокола формата NMEA0183..." на закладку "Тест" добавлен ползунок, демонстрирующий положение указателя при чтении файла. Позволяет быстро переместиться в любую точку трассы.
Добавлены средства работы с GPS-приемником MAGELLAN (Meridian):
- сохранение на карту путевых точек из GPS-приемника;
- загрузка выделенных точечных объектов в раздел "Пользовательские путевые точки" приемника;
- выбор редактируемой карты, кодов точечного и линейного объектов, семантик для занесения имени и описания путевой точки и т.д. через диалог "Настройка...";
- удаление путевых точек;
- удаление маршрутов.

2). Доработана задача "Редактор классификатора". В закладке "Объекты" добавлен режим "Копирование серии объектов" для облегчения создания новой серии объектов, когда вид объекта зависит от семантики. В векторных объектах для семнатик типа классификатор список строк) возможно отображение кода значения или соответствующей строки.
В параметрах условного знака (Вид объекта) возможно комбинировать стандартные и пользовательские примитивы. Примеры новых знаков на карте Data\Shape в инсталляции.
При импорте классификатора реализован перенос CMYK-палитры.

3). Добавлена новая задача "Формирование отчета классификатора в виде таблицы Exсel" (RSCEXCEL.DLL).

4). Добавлена новая задача "Перекодировка объектов карты". Используется для смены классификатора карты. Задача обрабатывает два классификатора и таблицу перекодировки, содержащую списки соответствия ключей объектов и кодов семантических характеристик классификатора исходной карты ключам объектов и кодам семантических характеристик классификатора производной карты. Карта с новым классификатором сохраняется в другой директории.

5). В диалогах редактирования текста подписи и значений текстовой семантики по клавише INS можно выбрать символ TrueType из таблицы и вставить в текущую позицию. Шрифт выбирается из шрифта, заданного в классификаторе для данной подписи или семантики.

6). Для удобства редактирования текстовой семантики в диалоге Выбора объекта разным семантикам могут соответствовать разные текстовые файлы из которых выбираются значения семантик. Имя файла, указанного пользователем, сохраняется в INI-файле карты с кодом семантики.

7). В диалоге Выбор объекта в меню по правой кнопке мыши можно изменить способ отображения метрики объекта на карте. Контур объекта может быть представлен на карте ломаной линией, или динамически формируемым огибающим или сглаживающим сплайном.
Добавлен выбор единицы измерения для отображения длины и площади объекта в мм на карте (в дополнение к метрам/километрам и гектарам).

8). Доработана задача Геодезический редактор. Обеспечивается обработка участков с частями в диалогах "Формирование межевых дел" и "Обработка атрибутов объектов", формирование отчетов для группы выделенных объектов.
В диалоге "Построение теодолитного хода" возможно добавление к проекту новых данных.
Плановая и высотная съемка расчитывается в одном диалоге "Решение прямых геодезических задач".
Выполняется округление координат в соответствии с настройками проекта при чтении\записи файлов разных форматов (CSV, XYH, DBF и другие).
Добавлен новый режим "Создать объекты из файла *.cxyz" на палитре "Обработка файлов обменных данных". Режим предназначен для потоковой загрузки большого количества точечных объектов (более 500 000) и может быть применен при чтении измерений лазерного сканирования местности.
Доработано формирование отчетов по набору участков:
- добавлено сообщение на выбор варианта формирования отчета по выделенным или по одному объекту. По каждому участку формируется свой отчет (новый экземпляр Word). В случае единого землепользования (участок из нескольких частей) формируется один экземпляр Word и в него вставляется описание всех частей. Для идентификации части на схеме и в отчете используется семантика СОБСТВЕННОЕ НАЗВАНИЕ, если она не заполнена, то названия частей не выводятся.
- добавлена возможность обработки внутренних объектов для группы выделенных участков. Пользователь может указать вариант обработки группы выделенных участков: как единое землепользование или каждый участок самостоятельно.
Доработан диалог "Формирование межевого дела":
- усовершенствован механизм оботражения связанных с картой записей (запись выделяется желтым цветом, подсчитывается количество частей участка, в том случае если это единое землепользование (используется семантика набор объектов), запрашивается значение площади объекта (в том числе с частями) и выдается в соответствующее поле;
- расширен перечень полей для атрибутивных данных об участке;
- добавлена возможность хранения информации о теодолитном ходе (TEO), полярках (TPR) и обратной геодезической задаче (TOB) с персонализацией для каждого отдельного участка. Теперь данные хранятся в записи БД.
При формировании "Межевого дела" для одиночных участков добавлена возможность поиска и обработки соседей.
Добавлен новый режим "Формирование подписей геодезических координат точек объекта". Функционирует только для карт, поддерживающих геодезическую систему координат.
В режиме "Формирование подписей координат точек объектов" подписи создаются по заданному формату представления координат (число знаков после десятичной точки).
При создании объектов из файла CSV выполняется нанесение подписей (номер точки/имя точки, координаты XYH) рядом с созданным объектом.
Доработан режим "Создать объекты из файла *.XYH". Добавлен ряд элементов, позволяющих управлять отображением статистики. Повышена скорость загрузки данных из файлов больших объемов (> 1 000 000 точек). Имеется возможность указывать наличие/отсутствие номера точки в первой позиции строки данных. Введен ряд параметров, позволяющих отключать статистику для загрузки файлов больших размеров.
В диалогах "Построение теодолитного хода" и "Решение прямых геодезических задач" добавлена возможность сохранять в текстовом файле измеренные растояния, а также возможность ввода этих расстояний в таблицу из текстового файла.
Добавлен новый диалог "Отчет по измерениям методом полярных координат" и формирование схемы по измеренным данным. Вызывается из диалога "Решение прямых геодезических задач".
Добавлен учет флага "Название объекта" при обработке одного или нескольких выделенных объектов. На схему наносится подпись названия участка. Для текста подписи используется семантика "НАЗВАНИЕ СОБСТВЕННОЕ" (9). Для единого землепользования не работает, так как там формируются подписи названия частей.
Добавлен учет флага "площадь объекта" при обработке одного или нескольких выделенных объектов. На схему наносится подпись площади участка. Число знаков после запятой берется из параметров дилога "Создание схемы". Для единого землепользования не работает, так как там нужно подписывать площадь каждой части.
Добавлена возможность указания папки данных по умолчанию. Для TEO, TPR, TOB и TAHEO используется именно этот параметр при инициализаци диалогов сохранения и от него формируются короткие имена файлов. Для шаблонов в качестве папки по умолчанию используется папка, в которой расположена программа. Для остальных файлов используется в качестве папки по умолчанию дирректория, в которой расположена карта.
В диалогах "Параметры геодезического редактора" и "Формирование схемы участка" добавлен элемент для управления единицами представления площади (кв.м, га и кв.км).
Внесены изменения в режимы формирования отчетов и "Подписать площадь" для использования различных единиц представления площади.
Добавлен элемент в диалоге "Формирование схемы" для управления выбором: искать или нет соседние участки при заполнении отчета.
Добавлена возможность формирования отчетов с выбором ведомостей из списка для потоковой обработки выделенных объектов. Добавлена возможность автоматического сохранения полученных отчетов в файлы. Имя файла создается по номеру объекта.
В диалоге "Настройка параметров для геодезии..." добавлена кнопка "Импорт", предназначеная для загрузки настроек, выполненных в других проектах.
Добавлена обработка новых ключевых полей: DIR_BE (дирекционный угол) и LINE_BE (длина линии). Значения данных полей рассчитываются на основе значений координат начальной (XB, YB) и конечной (XE, YE) точек теодолитного хода (исходных пунктов). Для работы программы в таблице БД "Учетные данные" должны присутствовать поля с соответствующими именами, или в семантике объекта должны быть заполнены характеристики с соответствующими ключами.
Добавлен новый режим: "Нарезка площадей". Режим обеспечивает создание новых объектов заданной площади или нарезку исходного полигона на N новых площадей равной площади.
В диалогах "Построение теодолитного хода" и "Решение прямых геодезических задач" добавлен скроллинг колесиком мыши по всем данным листа расчета;

9). Доработана задача Импорт геодезических измерений с приборов.
Изменен алгоритм обработки файла формата М5. Предусмотрена возможность обработать формат М5, если отсутствуют ключевые слова, указывающие, что произведено измерение на заднюю точку и на переднюю точку. Признак измерения на точки теперь определяется по ключевому слову "SD", а значения измеренных дирекционных углов вычисляются по предоставленным координатам точек.

10). Доработана задача Импорт данных из текстового файла (GEOIMPRT.DLL). Добавлена возможность создания подписей (название точки, высота, координаты XY) в наборе с точкой. Добавлена настройка кодов создаваемых подписей, округление координат создаваемого объекта, отображение формата координат.

11). При печати карты в PostScript файл добавлена возможность выбора цветовой модели - RGB или CMYK. Значение цвета не вычисляется, а выбирается из таблицы в классификаторе RSC.

12). Обновлен режим работы Редактора карты - Расчеты по семантике. Позволяет обновить значение заданной семантики для выделенных объектов по заданной формуле. В состав формулы могут входить различные математические функции, значения заданных семантик, константы, площадь, периметр и т.п.
Доработано создание Автофигур. Добавлена возможность настройки параметров насыпей, в том числе добавлена возможность настройки длины коротких штрихов в зависимости от длины длинных.
Добавлена возможность создания укрепленных откосов.
Доработан диалог редактирования метрики объекта.
Доработана сшивка площадных объектов, когда объекты находятся на расстоянии друг от друга - позволяет сшивать полигоны без ручного дотягивания точек.
При создании линейных и площадных объектов произвольного контура реализован захват точек и линий существующих объектов и добавлены вспомогательные панели.

13). Доработано отображение утолщенных линий и окружностей в экранном виде (убраны разрывы).

14). В задаче Построение координатной сетки добавлена возможность задать шаг сетки в секундах.

15). Изменено размещение файла Panorama.ini - в директории Temp. При первом запуске содержимое файла копируется из директории ГИС в директорию Temp.

16). В диалоге Список данных электронной карты доработана обработка растров:
- добавлен режим "Изменение привязки растров на DX,DY";
- в диалоге "Управление палитрой" (пункт меню Яркость/контрастность добавлен режим - "Для всех растров", при выборе данной строки изменения яркости, контраста и нелинейной яркости выполняются для всех растров.
Для диалога "Нарезка растра по выбранной области" реализован выбор области по объекту.
В нарезке по номенклатурам добавлена обработка масштабов 1 : 25 000, 1 : 10 000.

17). Добавлена новая задача "Преобразование растра к заданной проекции" (RSWPROJ.DLL). Если в паспорт растра занесены параметры проекции (при импорте данных или введены пользователем), то можно преобразовать растр в другую проекцию, выбранную пользователем.

18). Добавлена новая задача "Нарезка матриц" (MTWCUT.DLL). Позволяет вырезать новые матрицы из существующих по границам выделенных объектов или по выбранной области.

19). Доработана задача построения матрицы высот. Добавлена возможность выбора режима дополнительной обработки высотных точек при создании матрицы высот:
- построение лучей влияния высоты (если карта содержит изолинии и отметки высот - традиционный рельеф);
- построение сетки треугольников (если карта содержит много отметок высот и возможно изолинии);
- дополнительная обработка отсутствует (если карта содержит густую сетку отметок высот, например полученных приборами лазерного сканирования);

20). Доработана задача Построения горизонталей по матрице высот.
Добавлен параметр "Уровень учета кривизны поверхности рельефа" и изменен алгоритм сглаживания матрицы (наведения аналитической структуры). Задача различает равнинные и пересеченные участки матрицы и проводит различную степень модификации рельефа.

21). Добавлено перемещение карты (рука) при движении мышкой с нажатым колесиком.
В главную панель добавлена кнопка масштабирования "Вся карта в окне".
В меню Параметры добавлен вызов диалога настройки пути к папке с данными и пути к папке с общими классификаторами.

22). Доработан классификатор морских карт S57navy.rsc по стандарту S52.
Добавлены новые знаки - 187 точечных знаков и 43 линейных, переделан внешний вид 141 точечных знаков и 40 линейных. Внешний вид всех знаков сделан в соответствии с документом "SYMBOL LIBRARY FOR USE ON ECDIS" (ADDENDUM.doc).
Для всех новых и уточненных объектов добавлена семантика по списку в Каталоге объектов МГО.
Знаки дополнены подписями по семантике в соответствии с описанием знака. Для некоторых семантик поправлен перевод и добавлены отсутствующие значения.
Уточнены параметры цветов.