Что нового в последней версии ГИС Карта 2005

ГИС Карта 2005 (Версия 8.05 (Последний выпуск 8.05 #7))

1. Внесены изменения в алгоритм построения транспортной сети в задаче Расчеты по карте . Время построения сети уменьшено в 1,5-2 раза. Добавлено формирование файла протокола .log и нанесение на карту с сетью объекта "Ошибка сети" (например, при наличии петель в исходной метрике объектов).

2. В диалоге Выбор объекта в закладке Метрика добавлена возможность отображения и редактирования геодезических координат объекта в системе WGS-84.
Добавлена возможность просмотра списка объектов, которые попадают в окрестность выбора в данной точке. Поле Имя объекта содержит раскрываемый список для прямого выбора требуемого объекта.

3. Изменен порядок выбора объектов в точке. Во всех режимах редактора, кроме редактирования подписей, подписи выбираются в последнюю очередь. Для изменения порядка выбора используйте пункт Выбор подписи последней в меню Параметры .

4. Доработана задача Построения трехмерного изображения карты (Задачи\Навигатор 3D).
Появилась возможность быстрого перехода в нужную точку 3D-модели по нажатию мыши. Добавлены кнопки Сохранение текущих настроек модели , Восстановление сохраненных настроек модели , в настройках запоминается и положение на модели.
При входе в задачу начальные настройки модели сохраняются автоматически.
В пункте меню Освещение появился подпункт Прожектор . При его включении отлючается естественное освещение модели (солнцем по времени суток) и включается источник света, освещающий модель все время от наблюдателя.
Настройка данного режима также сохраняется в ini-файле для следующего сеанса работы.
Появилась возможность ориентации точечного трехмерного знака: для векторных объектов - по метрике; для линейных объектов: знак вдоль линии - по метрике, знак в опорных точках - по метрике предыдущего отрезка, по метрике следующего отрезка, по биссектрисе угла между двумя прилегающими отрезками.
Ориентация знака задается в редакторе классификатора при создании (редактировании) трехмерного изображения объекта.
Расширен перечень отображаемых трехмерных элементов - добавлено рисование скатов (крыши и т.п.).
В редакторе классификатора на закладке 3D Библиотеки появились возможности просмотра ВМР-файла в качестве текстуры и сохранения существующей текстуры в BMP- файл.
Появилась возможность направленного наложения текстур на горизонтальные поверхности (вдоль большей стороны).
Сделан вывод подсказок по кнопкам и пунктам меню в строку состояния главного окна ГИС.
Новая функция для площадных объектов прямоугольной формы позволяет строить по ним горизонтальные цилиндрические поверхности с возможностью наложения текстур и выбором частей рисования (стенки, боковые основания, каждое в отдельности).
Добавлен демо-режим Свободный полет по траектории лемнискаты (восьмерка).
Появилась возможность просмотра информации об объекте в окне трехмерной модели местности. Диалог выбора объекта открывается по нажатию левой кнопки мыши.
При нажатии правой кнопки мыши выполняется быстрый переход в точку.
Появилась новая опция описания вида площадного объекта (в знаке по площади добавлен произвольный поворот знака). Опция позволяет формировать нерегулярный вид расположения знаков по площади.
В инсталляцию входит пример 3D-библиотеки standard.p3d для плана \Data\Cadastre.

5. Доработана задача База данных:
В Конструкторе форм добавлены макросы:
- запуска формы, имя которой находится в таблице;
- заполнения названия формы пользователя;
- запуска Dll;
- запуска внешних программ Exe с параметрами из таблицы.
В режиме Геокодирование добавлена автоматическая настройка имен полей.

6. Доработана задача Геодезические расчеты .
Изменена нумерация точек объектов на схеме и в отчетных ведомостях.
Добавлена возможность нумеровать точки значением из семантики или по порядку, начиная с заданного значения с добавлением префикса.
В диалоге Тахеометрия предоставлена возможность значения зенитных расcтояний, введенных в колонку "верт.угол", преобразовать в значения вертикального угла.
В диалоге "Решение обратных геодезических задач." формирование схемы участка и печать можно выполнить без нанесения участка на карту; расчет площади участка выполняется как с учетом рельефа (если введены высоты точек), так и без учета рельефа.
При запуске Геодезического редактора в главном меню добавляется раздел Геодезия для удобства вызова геодезических задач.
Доработана прикладная задача Формирование протокола GPS-измерений . Задача вызывается из геодезического редактора. Добавлено формирование ВЕДОМОСТИ КОНТРОЛЬНЫХ ИЗМЕРЕНИЙ по шаблону, формирование КАТАЛОГА КООРДИНАТ ПУНКТОВ по шаблону; для документа Протокол Gps измерений добавлен расчет и занесение параметра Время стояния на точке инициализации , добавлена фильтрация списка исходных пунктов при инициализации диалога в зависимости от системы координат карты; добавлено округление координат, расстояний, площадей.
Количество знаков после запятой устанавливается в параметрах геодезического редактора.
В режимах Создание линейных объектов из файла CSV и Создание площадных объектов из файла CSV добавлена возможность записи в семантику объекта имени файла, времени и даты.

7. Обновлена задача Подключение GPS-приемника.
Добавлена возможность выбора модели устройства из списка (Закладка Настройка порта ).
Добавлена закладка Сервис для получения информация об устройстве (версия ПО, уникальный номер устройства, модель устройства, фирма производитель) и для загрузки из устройства путевых точек и установленных маршрутов.

8. Доработана задача Расчеты по карте . В панель Работа с выделенными добавлен новый режим Вычисление значения семантики в заданной точке - выполняет интерполирование значения заданной семантики с учетом значения этой семантики у окружающих объектов (всех видов или среди выделенных).
В диалог калькулятора добавлено поле для выбора точности отображаемого значения.

9. В задаче Сортировка объектов карты добавлен режим Нормальная точность координат - для приведения координат всех объектов к одному формату без увеличения объема данных.
Единая точность координат объектов (нормальная или повышенная) необходимы для корректного выполнения топологических операций.

10. Доработаны средства редактирования метрики объекта в табличном виде. Разработан новый диалог редактирования координат. Обеспечивает непосредственный ввод значений прямоугольных и геодезических координат точек объекта, вычисление координат текущей точки по заданным значениям приращений координат, а также прямых расстояний и углов (дирекционный, левый и правый поворотные, румб) относительно предыдущей точки. Диалог вызывается при выборе объекта, когда нажата кнопка главной панели с символом М или при создании нового объекта по "Ins".

11. В параметрах вида объекта добавлен пункт Не сжимать - для сохранения размеров условного знака объекта при сжатии карты. Ранее был только пунт - Масштабируемость (увеличение размеров объекта при увеличении размеров карты). Чтобы размер был постоянный нужно отключить Масштабируемость и включить Не сжимать .

12. Доработано отображение наносимых OLE-объектов (прозрачный фон, печать, редактирование).

13. В диалоге печати добавлена возможность установить область по выбранному объекту.

14. В разделе Подготовка к изданию списка прикладных задач добавлена новая задача - Сохранение оформительской легенды (LBLSAVE.DLL). Обеспечивает формирование элементов зарамочного оформления типа схема, угловой штамп, масштаб заложений, легенда знаков и т.п., которые могут быть подготовлены на пользовательской карте и вставлены в описание зарамочного оформления.

15. Для площадных объектов добавлен вид Направления цифрования - Произвольное . Необходимо для тех видов объектов, которые могут изменять направление по указанию оператора. Остальные объекты автоматически принимают заданное направление цифрования.

16. Доработана задача Построение координатной сетки на район работ (MAKEGRID.DLL).
Добавлен выбор кода объекта и кода семантики и для горизонтальных и для вертикальных линий (ранее строились одним кодом).

17. Добавлен пункт меню Файл\Создать\Район работ . Позволяет набрать в локальной сети список файлов SXF из которых формируется район работ.

18. Доработан интерфейс задачи Проводник карт (пункт меню Файл/Проводник карт).
Реализована возможность множественного выделения узлов Дерева данных для редактирования. В меню Правка и во всплывающее меню добавлены пункты: Копировать, Вырезать, Вставить. Реализована возможность перетаскивания узла Дерева в другие ветки.

19. В интерфейс PanTask для прикладных задач добавлены функции управления главным меню ГИС (добавить, удалить пункты меню, скрыть показать и т.п.).

20. При импорте растровых данных добавлена поддержка файла привязки растра в формате TAB (MapInfo).

21. Доработан конвертор из формата S57 . Добавлена поддержка входных данных в системах координат "S42 (Pulkovo42)" и "NAHRWAN". Ранее поддерживалась только WGS-84.

22. Доработан конвертор из формата DXF . Добавлена загрузка примитива DIMENSION.
Добавлено масштабирование для типов LINE, POLYLINE, VERTEX, LWPOLYLINE при вставке.
Обеспечена замена описания блока точечным или векторным знаком в режиме загрузки по таблице настроек. Сообщения о количестве ошибок (не обработанных примитивах) выводятся в форму.

23. Доработан конвертор из формата DXF . Добавлена загрузка примитива SPLINE.
При замене описания блока точечным или векторным знаком в объекты добавляется семантика 9 (собственное название), значение которой есть имя блока ACAD.

24. Расширен список команд, выполняемых с клавиатуры (см. меню Помощь\Горячие клавиши).

25. Разработано новое приложение - Редактор поверхности (\Surface). Программа предназначена для обновления трёхмерной карты местности в стереорежиме, а также для определения высотных характеристик объектов электронных карт с целью уточнения трехмерной модели местности.