Что нового в последней версии ГИС Карта 2005

ГИС Карта 2005 (Версия 9.01 (Последний выпуск 9.01 #9))

1). Для упрощения перехода между перекрывающимися картами, имеющими разный масштаб, добавлена задача АТЛАС КАРТ. Имя создаваемого или открываемого атласа выбирается в диалоге Атлас карт (меню Окно\Открыть атлас).
Для перехода к другой карте можно воспользоваться пунктами меню Окно\Перейти к карте – Более мелкого масштаба, Самой мелкой, Более крупного масштаба, амой крупной, Выбрать из списка.

2). Добавлены средства создания, отображения и применения TIN - МОДЕЛИ. TIN-модель представляет собой многогранную поверхность - нерегулярную сеть треугольников, вершинами которых являются исходные опорные точки, а также точки метрики структурных линий и площадей заполнения.
TIN-модель поверхности строится по данным исходной векторной карты, содержащей опорные точки, структурные линии и площади заполнения постоянным значением. При построении TIN-модели используются объекты карты с семантической характеристикой "абсолютная высота" и объекты с трехмерной метрикой.
Для плоского отображения TIN-модели в виде закрашивания областей с одним диапазоном высот используется та же палитра, что и для матрицы высот. При схематичном отображении будут видны только рёбра треугольных граней, составляющих поверхность. Рёбра при этом отображаются первым цветом палитры.
Наличие TIN-модели в списке данных электронной карты позволяет: выбрать значение абсолютной высоты в заданной точке; построить профиль по заданной трассе (ломаной линии) или по объекту векторной карты; построить зону видимости для участка местности; определить длину объекта с учётом рельефа и т.п.

3). Новые возможности задачи трехмерного изображения карты (Задачи\Навигатор 3D). Изменен принцип движения по 3D-модели, теперь можно перемещаться с одновременным поворотом, изменением угла наклона модели и регулировкой скорости движения по 3D-модели.
Появилась возможность задания и редактирования трехмерного вида объекта не выходя из 3D-модели. По нажатию левой кнопки мыши появляется окно просмотра информации об объекте, находящемся в данном месте карты, вне зависимости от наличия у объекта трехмерного вида. Через это окно можно зайти в редактор классификатора и изменить трехмерный вид объекта или назначить новый. После сохранения изменений вид объектов на модели будет обновлен. Просмотр информации об объекте при работе с трехмерной моделью теперь возможен в двухмерной и трехмерной карте.
В редактировании трехмерного вида объектов появилась новая функция для площадных объектов - "поверхность" (горизонтальная поверхность с учетом высот модели).
Появилась возможность при отображении трехмерного вида конкретного объекта брать текстуру из его семантики. Это задается при редактировании трехмерного вида объекта в классификаторе способом выбора текстуры для отображения.
При редактировании классификатора стало возможным удалять ненужные текстуры из 3D-библиотеки (p3d). Добавлен режим переноса изображения отдельного объекта из одной 3D-библиотеки в другую. (#6)
При сохранении параметров сеанса работы с 3D-моделью запоминается положение точки наблюдения, оно воостанавливается при следующем вхождении.
При работе с 3D-моделью стало возможным рассмотреть объекты в каркасном виде.
Текущее изображение может быть записано в файл типа "BMP" (файл создается автоматически в директории с данными, имя файла задается по времени создания).
Доработана видеозапись в файл типа "AVI" по заданной ранее траектории движения по трехмерной модели. При записи траектории сохраняются все настройки работы с трехмерной моделью (изменения освещенности, масштаба, вида рельефа и объектов и т.д.). Изменением количества записываемых кадров можно менять плавность движения в видеозаписи. Можно записать видео как по всей сделанной траектории, так и по ее части. Траектории сохраняются в файлах с расширением TRA.
Добавлен режим просмотра 3D-модели по заданной траектории. (#7)
В диалоге Выбор объекта добавлена закладка 3D для просмотра и редактирования трехмерного вида объекта. (#6)
Разработана технология построения трехмерных моделей местности (DOC\MODEL3D.DOC).

4). Добавлена возможность отображения векторных карт, растров и матриц в виде ВРЕЗКИ. Данные отображаются на фоне основной карты в своей проекции, системе координат и масштабе в отведенном участке. Размер, положение, цвет фона, цвет и толщину рамки, границы видимости врезки можно изменять. Список врезок доступен через меню Вид\Список документов, закладка Врезка. Свойства врезки можно изменять через меню по правой кнопке. Описание врезок сохраняется в INI-файле. Для вставки набора пользовательских карт, растров и матриц нужно сохранить описание данных в проект (файл MPT) и затем вставить его во врезке.

5). Доработана задача База данных. Диаграмму, которая строится по результатам анализа таблиц базы данных с помощью соответствующего компонента Конструктора Форм БД, можно наносить на карту, как OLE - документ.

6). Доработана задача Редактор карты. В группу АВТОФИГУРЫ добавлены два новых режима: Формирование бергштриха в указанной точке и Формирование парных бергштрихов на замкнутой горизонтали.
Добавлен режим отображения общих точек 2-ух объектов (красные точки принадлежат только первому объекту, желтые - второму, зеленые - общие).

7). Доработана задача Расчеты по карте. В режиме "Абсолютная высота" добавлен вывод значения максимального уклона в точке и направление максимального уклона при наличии матрицы высот.
Добавлен новый режим "Пересчет координат в текстовых файлах". В диалоге задаются параметры входной и выходной проекции, после чего выполняется пересчет списка координат точек, записанных построчно в текстовом файле.
В диалоге "Трехмерное отображение матрицы слоёв" добавлена закладка "Легенда" (#6).

8. Разработана новая задача "Импорт геодезических измерени" (GEOLOAD.DLL).
Усовершенствована обработка форматов RAW; GTS (6, 600, 7, 700); DC1 (PENTAX)
и других (3TA5, SDR33, M5, R5, R4). (#7)
Обрабатываются следующие виды ходов: разомкнутый (классический); замкнутый; сомкнутый; с 1-м примычным углом; свободный (висячий); с координатной привязкой. Загружаемые данные отображаются в виде цветной схемы. Разработан и документирован обменный формат измерений ТЕО/TPR (DOC\GEOBIN.DOC). Статью "Импорт данных из геодезических приборов в ГИС" можно посмотреть здесь.

9). Доработана задача Геодезический редактор. (#6) Добавлен режим "Автоматическое заполнение семантики выделенных объектов" (например, имя объекта, номер точки и т.п.), добавлен режим "Перенос семантики в выделенные объекты" из указанного объекта.
Добавлена возможность обработки участков с частями. Добавлено новое ключевое поле для отчетов: #PART# - количество частей участка.
Добавлен новый параметр формирования отчетов для описания прохождения границ строений.
Расширен диалог "Создание схемы участка", добавлена обработка семантик "НОМЕР ЧАСТИ УЧАСТКА", "ДОЛИ УЧАСТКА", "ОБРЕМЕНЕНИЯ НА УЧАСТКЕ".
При формировании схемы для участка с частями наносится подпись по семантике, соответствующей номеру части участка.
В форму "Таблица данных тахеометрии" из состава геодезических задач добавлена кнопка выбора "Тип прибора геодезической съемки (аналоговый \ цифровой)".
В зависимости от "типа прибора" изменяется алгоритм вычислений. (#7)
Добавлена возможность вывода на схему дирекционных углов и мер линий в виде дроби возле текущего отрезка метрики.
Добавлена возможность формировать в одном сеансе рисунок схемы с различным содержанием, для этого введены новые ключевые поля: #PICTURE_0# - разбивочный чертеж,
#PICTURE_1# - схема границ земельного участка, #PICTURE_2# - список межевых знаков,
#PICTURE_3# - учетная карточка, #PICTURE_4# - карта (план) границ,
#PICTURE_5# - чертеж земельного участка.
Добавлен новый режим "Сформировать набор: участок и его части". По выделенным объектам формируется составной участок - единое землепользование. Для связи с таблицей"Учетные данные" необходимо использовать главный объект набора.
Обновлены шаблоны отчетов. Добавлены шаблоны для отчетов по участкам под ЛЭП.

10). Разработана новая прикладная задача "Объединение матриц высот" (MTWSUM.DLL). Задача предназначена для формирования обобщенной матрицы высот. Исходными данными являются одна или несколько открытых матриц высот. В каждый элемент выходной матрицы заносится высота из матрицы, содержащей высоту в этой точке. Если для точки имеется несколько матриц высот, то в выходную матрицу заносится высота из матрицы с наименьшим размером элемента (более точной). Значение высоты в точке определяется методом триангуляции. Предварительно матрицы могут быть обработаны с помощью задачи Уравнивание матриц высот.

11). Разработана новая прикладная задача "Сравнение матриц высот" (MTWCOMP.DLL). Задача предназначена для сопоставления информации двух однотипных матриц высот. В выходную матрицу заносится разность высот второй и первой матрицы.

12). Доработана задача построения матрицы слоев (геологической) (меню Файл\Создать\Матрицу слоев). Для ввода повторяюшихся в точке слоев применяются повторяющиеся коды семантики (например, семантика песок с мощностью отдельных слоев может чередоваться с другими семантиками). Значения повторяющихся семантик будут занесены в матрицу в качестве мощностей слоев в соответствии с настройкой легенды матрицы.
В диалогах Профиль по линии (по матрице слоев) и Мощность в точке можно отображать короткое имя семантики (до 16 символов) или полное (до 32). Можно отключать отображение имен вырожденных слоев (имеющих нулевую мощность на данном участке).

13). Разработана новая прикладная задача "Построение диаграммы и графика" (MAPCHART.DLL).
Задача предназначена для создания диаграмм и графиков различных типов, в том числе объемных. Построение осуществляется на основе значений семантической характеристики выбранных объектов. Имеется большое число параметров настройки вида диаграмм, графиков и их легенд. Построенный график или диаграмма наносятся на карту в виде EMF-файла (OLE-объекта).

14). Разработана новая прикладная задача "Контроль векторных объектов" (VECTCORR.DLL). Задача предназначена для исправления метрики векторных объектов - длины и числа точек.

15). Доработан конвертор из формата DXF. Добавлена обработка нормали в примитиве INSERT, при обработке сплайна добавлена загрузка из контрольных точек, если точки сглаживания отсутствуют. Добавлена загрузка примитивов TRACE, ELLIPSE. Добавлена загрузка кольца. Доработана загрузка HATCH (площадей с подобъектами из штриховок с несколькими уровнями вложенности).

16). Доработан конвертор из формата S57. Добавлено формирование подписей по характеристике 116 (Имя объекта).

17). Добавлена поддержка геодезических координат при работе с растрами и матрицами. Для пересчета координат можно задать параметры проекции и тип эллипсоида.

18). Добавлена поддержка формата координат в градусах, минутах, секундах при экспорте координат объектов в текстовый файл или DBF-таблицу.

19). Доработана задача Формирование координаты высоты объектов гидрографии (MAPHYDRO.DLL). Применен новый алгоритм интерполяции высот (формируется граф сети гидрографии c обработкой треков гидрографии в порядке убывания длины). Улучшены алгоритмы отсечения рукавов у площадных рек и формирования фарватеров площадных рек. Улучшены средства контроля метрики объектов гидрографии на монотонность убывания высоты от истока к устью.

20). Обновлен диалог Перейти к точке. Кроме ввода абсолютных значений координат добавлен переход по Азимуту и Расстоянию и по Приращению координат текущей точки.
Добавлена настройка "Закрывать окно диалога после выполнения перемещения". (#7)

21). В диалоге Списки объектов (меню Поиск\Списки объектов) добавлена закладка ПОСТРОЕНИЯ для выполнения топологических операций над списками. В закладке Поиск добавлены режимы "Пересечение и внутри" и "Полностью внутри".

22). В редакторе классификатора добавлена возможность представлять таблицу объектов в виде дерева. Дерево строится автоматически по внешним кодам объектов.

23). Доработан конвертор из формата TIFF. Добавлена обработка несжатых однобитовых файлов TIFF и однобитовых файлов TIFF со стриповой структурой, сжатых методом CCITT/3.
Добавлена обработка файлов TIFF с матрицей трансформирования (из MicroStation) и поддержка линейных размеров в миллиметрах (из MicroStation) для привязки растра в местной системе координат.
В диалог "Сохранение карты в TIFF" добавлены флаги "Сжатие PackBit" для любого числа бит на пиксел (#7) и "Intergraph Tiff" для формирования тега "Матрица трансформирования" (#7).

24). При сохранении карты в текстовый формат SXF (TXF) с прямоугольной системой координат добавлена возможность выбора числа знаков после запятой. (#6)

25). Доработана задача Построение стандартной разграфки топокарт (MAPRULE.DLL). Обеспечивается построение разграфки на картах масштаба 1:500-1:2000 и возможность выбора произвольного размера наносимой разграфки в географической системе координат (ранее размер наносимых рамок строго определялся масштабом карт). (#6)

26). Для подготовки фрагмента карты к печати добавлен пункт меню Файл\Выделение фрагмента. Позволяет вырезать область карты со всеми данными в отдельное окно. Вырезанные данные копируются в поддиректорию Print. Их можно произвольным образом подредактировать и распечатать, не изменяя основной карты. (#7)

27). Доработана задача Построение изолиний по точечным объектам (ISOLINES.DLL). (#7)
Добавлен выбор порядкового номера утолщенной горизонтали (3-я, 4-я или 5-я).

28). Обновлена библиотека отображения программируемых знаков Shape.iml. Тексты в \SDK\Imlapi.
Добавлено отображение векторных знаков с линией выноски и подписями характеристик из семантики. Примеры объектов на карте \Data\Shape.

29). Доработан классификатор map500.rsc для работы с топографическими планами масштаба 1:500.
В таблицу шрифтов добавлены шрифты с пользовательскими названиями, соответствующими топографическим шрифтам. Для правильной печати карты нужно установить на ПЭВМ шрифты из файла \Fonts\Texts.zip с компактдиска и изменить ссылку в таблице шрифтов с Arial на топографический шрифт в соответствии с его названием.
Добавлены векторные объекты 51316610 - 51316610, люки с выносной линией и сложной подписью (цифруется тремя точками - люк и выносная линия, текст для подписей берется из семантик; cемантика "Сложная подпись(часть1)" содержит текст для числителя, семантики "Сложная подпись(часть2)" - "Сложная подпись(часть8)" - для знаменателя в несколько строк.
Доработаны знаки подземных коммуникаций.
Добавлен классификатор map500.print.rsc с настроенной таблицей шрифтов для издания. (#7)