Техническая поддержка - Обработка растровых изображений

1. Общие возможности ГИС Карта 2000 по обработке растровых изображений

ГИС Карта 2005

1.1. Понятие растровой карты

Растровая карта в ГИС "Карта 2000" имеет формат RSW. Формат разработан в 1992 году, по структуре близок к формату TIFF версии 6. Основными показателями, характеризующими растровую карту, являются:

  • масштаб изображения;
  • разрешение изображения;
  • размер изображения;
  • палитра изображения;
  • плановая привязка изображения.

Масштаб изображения - величина, характеризующая исходный материал (в результате сканирования которого было получено данное растровое изображение). Масштаб изображения - это отношение между расстоянием на исходном материале и соответствующим расстоянием на местности.

Разрешение изображения - величина, характеризующая сканирующее устройство, на котором было получено растровое изображение. Величина разрешения показывает, на сколько элементарных точек (пикселей) устройство сканирования разбивает метр (дюйм) исходного изображения. Иными словами данная величина показывает величину "зерна" растрового изображения. Чем больше величина разрешения, тем меньше "зерно", а значит меньше размер объектов местности, которые можно однозначно идентифицировать (дешифрировать)

Размер изображения (высота и ширина) - величины, характеризующие само изображение. По этим величинам можно определить габаритные размеры растрового изображения в пикселях (точках). Размер изображения зависит от размеров сканируемого исходного материала и установленного значения разрешения.

Палитра изображения - величина, характеризующая степень отображения оттенков цвета исходного материала в растровом изображении. Существуют следующие основные типы палитры:

  • двухцветная (черно-белая, один разряд);
  • 16 цветов (или оттенков серого цвета, четыре разряда);
  • 256 цветов (или оттенков серого цвета, восемь разрядов);
  • High Color (16 разрядов);
  • True Color (24 или 32 разряда).

В случае возможности выбора при сканировании исходных материалов величины разрешения и палитры изображения (некоторые сканирующие устройства работают только с фиксированными значениями), следует учитывать, что при увеличении разрешения и выбора более высокой степени отображения оттенков резко возрастает объем получаемого файла, что в последствии скажется на объемах хранимой информации и скорости отображения и обработки растрового изображения. Например, при сканировании исходных картматериалов нет необходимости применять палитру более 256 цветов, так как реально на обычной карте, как правило, присутствует не более 8 цветов.

Палитра изображения хранится в исходном файле, а разрешение и масштаб будущего изображения следует ввести при конвертировании растра во внутренний формат. Исключение составляют файлы формата TIFF, в которых помимо палитры хранится и разрешение. Для остальных случаев разрешение указывается в соответствии с параметрами, выбранными при сканировании. Например, отечественные барабанные сканеры фирмы КСИ сканируют с разрешением 508 точек/дюйм (или 20000 точек/метр). Если Вы не знаете точное значение масштаба обрабатываемых материалов, следует ввести приблизительное значение (величина масштаба автоматически уточняется в процессе привязки растрового изображения).

Загруженное в систему растровое изображение еще не является растровой картой, так как не имеет плановой привязки. Непривязанное изображение добавляется всегда в юго-западный угол габаритов карты. Поэтому, если вы работаете с большим районом работ, для быстрого поиска добавленного растра можно воспользоваться пунктом "Перейти к растру" меню свойств растрового изображения диалога "Список растров".

После привязки растровая карта становится измерительным документом. По растровой карте можно определять координаты изображенных на ней объектов (при перемещении курсора по растровой карте в информационном поле в нижней части экрана отображаются текущие координаты). Привязанную растровую карту можно использовать как самостоятельный документ или в совокупности с другими данными.

1.2. Конвертирование растровых данных

Cистема Панорама обрабатывает растровые карты, представленные в формате RSW (внутренний формат системы). Данные из других форматов (PCX, BMP, TIFF) могут быть конвертированы в формат RSW с помощью программного обеспечения системы Панорама. Кроме того, системой поддерживается ранняя версия структуры растровых данных RST ("Панорама под MS-DOS") . При открытии файла RST он автоматически преобразуется к формату RSW.

Существует два способа загрузки растрового изображения в систему:

  • Открытие растрового изображения как самостоятельного документа (пункт "Открыть" меню "Файл").
  • Добавление растрового изображения в уже открытый документ (векторную, растровую, матричную или комбинированную карту).Добавление растрового изображения в уже открытую карту производится через пункт "Добавить - Растр" меню "Файл" или пункт "Список растров" меню "Вид".

1.3. Привязка растровой карты

Привязка растровой карты производится по привязанному документу, т.е. вначале необходимо открыть документ, ориентированный в заданной системе координат (векторная, растровая или матричная карта), добавить в него привязываемый растр и выполнить привязку. Привязать растр можно одним из способов, предоставляемых в свойствах растра ("Список растров - Свойства"). Следует помнить, что все действия над растром, доступные в меню свойств растрового изображения, выполняются над ТЕКУЩИМ растром. Поэтому, если открытый документ содержит несколько растров, следует активизировать (выбрать в списке открытых растров) тот, с которым Вы в данное время хотите работать.

1.3.1. Привязка по одной точке

Привязка производится последовательным указанием точки на растре и точки, куда указанная точка должна переместиться после преобразования (откуда - куда). Преобразование производится путем параллельного перемещения всего растра без изменения его масштаба и ориентации.

1.3.2. Подвинуть в юго-западный угол

Преобразование производится путем параллельного перемещения всего растра без изменения его масштаба и ориентации в юго-западный угол габаритов района работ. Данный режим привязки целесообразно применять, когда к открытой карте Вы добавляете некорректно привязанный растр, который отображается далеко за пределами района работ. В этом случае после перемещения растра в юго-западный угол облегчается его повторная привязка.

1.3.3. Привязка по двум точкам с масштабированием

Привязка производится последовательным указанием пары точек на растре и точек, в которые указанные точки должны переместиться после преобразования (откуда - куда, откуда - куда). Преобразование производится путем параллельного перемещения всего растра с изменением его масштаба. Привязка изображения производится по первой паре указанных точек. Вторая пара точек указывается для вычисления нового масштаба растрового изображения. Поэтому в случае, если у растра значения вертикального и горизонтального масштаба не равны (растр вытянут или сжат вследствие деформации исходного материала или погрешности сканирующего устройства), вторая точка займет свое теоретическое положение с некоторой погрешностью. Для устранения погрешности следует воспользоваться одним из методов трансформирования растрового изображения (прикладная задача "Трансформирование растровых данных").

1.3.4. Поворот без масштабирования

Привязка производится последовательным указанием пары точек на растре и точек, в которые указанные точки должны переместиться после преобразования (откуда - куда, откуда - куда). Преобразование производится путем параллельного перемещения всего растра с изменением его ориентации в пространстве. Поворот осуществляется вокруг первой указанной точки. Привязка изображения производится по первой паре указанных точек. Вторая пара точек указывается для вычисления угла разворота изображения. Поэтому в случае, если у растра значения вертикального и горизонтального масштаба не равны (растр вытянут или сжат вследствие деформации исходного материала или погрешности сканирующего устройства), вторая точка займет свое теоретическое положение с некоторой погрешностью. Для устранения погрешности следует воспользоваться одним из методов трансформирования растрового изображения (прикладная задача "Трансформирование растровых данных").

1.3.5. Привязка по двум точкам с масштабированием и поворотом

    Привязка производится последовательным указанием пары точек на растре и точек, в которые указанные точки должны переместиться после преобразования (откуда - куда, откуда - куда). Преобразование производится путем параллельного перемещения всего растра с изменением его масштаба и ориентации.

1.3.6. Горизонтальное выравнивание

    При горизонтальном выравнивании положение растрового изображения меняется таким образом, что указанные на нем точки располагаются на одной горизонтальной линии. Поворот осуществляется вокруг первой из указанных точек.

1.4. Понятие растрового района

При загрузке растровых карт в базу данных может создаваться район работ растровых карт. Для создания растрового района необходимо последовательно загрузить в систему каждое образующее этот район растровое изображение и сориентировать его относительно единой системы координат.
    Комбинация растровых и векторных карт на одни и те же или смежные территории позволяет оперативно создавать и обновлять районы работ, сохраняя возможность решения прикладных задач, для которых некоторые виды объектов карты должны иметь векторное представление.

К оглавлению  Следующая глава